cPanel – PHP Selector ile PHP Sürümü Değiştirme

PHP programlama dili ile yazılmış yazılımların sürüm farklılıkları olabilir. Örneğin ioncube ile şifrelenmiş yazılımlar genel olarak 5.6 sürümü ile çalışmakta ve 7.1 üstü sürümlerde sorun yaşatmakta. Bu tip yazılımsal sorunlar için hosting hizmetinizin uygun sürüme sahip olması gerekir. Bu yazımda cPanel’de yer alan PHP Selector ile sürüm değiştirme işleminden bahsedeceğim.

PHP Selector Nedir? Ne İşe Yarar?

cPanel’de yer alan bir eklenti olarak düşünebilirsiniz. Sunucu firmaları, konfigürasyon yaparken PHP Selector eklentisini aktif hale getirebilmektedir. Böyle bir imkana sahipseniz, dilediğiniz zaman sürüm değişikliğine gitmeniz mümkün. Fakat değiştirebileceğiniz sürümler de yine aynı şekilde sunucu firmanız tarafından belirlenmektedir. Genellikle 5.x ve 7.x versiyonları bulunur.

İlk olarak yazılımınızın hangi PHP Sürümü ile uyumlu olduğunu ve hangi extensionsların gerekli olduğunu tespit etmeniz gerekiyor. Ardından düzenleme safhasına geçebilirsiniz.

PHP Selector ile Sürüm Değiştirme

cPanel > Yazılım > Select PHP Versiyon sayfasına gelin. Açılan sayfanın üst bölümünde sürüm seçenekleri bulunur. Size uygun olanını seçin ve “Set as Current” butonuna basın. Ardından extensions kısmını inceleyerek eklemek veya çıkarmak istediklerinizi işaretleyin. Son olarak “Kaydet” butonuna basarak işlemi tamamlayabilirsiniz.

Ayrıca aynı sayfada sağ bölümde bulunan “Switch To PHP Options” bölümünden sürüm ile ilgili hata gösterimini açık kapatabilir, memory_limit, max_input_time, open_basedir gibi değerleri düzenleyebilirsiniz.

!!! cPanel önbellekleme işleminden dolayı yaptığınız güncelleme direkt olarak aktif olmayabilir. Bu konuda biraz beklemeniz en sağlıklısı olacaktır.

OKUMALISIN!  cPanel - PHP Hata Mesajlarını Aktif Etme - Açma Kapatma

!!! Eğer yönetim panelinizde böyle bir alan bulunmuyorsa, sürüm değişikliğini sunucu firmanızla iletişime geçerek halledebilirsiniz.

1 Star2 Stars3 Stars4 Stars5 Stars (1 oylama, average: 5,00 out of 5)
Loading...

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir